Category: t3 extension development

PHP Fatal error: Class ‘tslib_cObj’ not found

03:54 PM by Christian Koch

Filed under php, t3 extension development

Last modified Wednesday September 9th, 2015

when you get the error "PHP Fatal error: Class 'tslib_cObj' not found" go to the file displayed in your error log and replace tslib_cObj with \TYPO3\CMS\Frontend\ContentObject\ContentObjectRenderer

PHP Fatal error: Class ‘t3lib_div’ not found

02:56 PM by Christian Koch

Filed under php, t3 extension development

Last modified Wednesday September 9th, 2015

when you get the error "PHP Fatal error:  Class 't3lib_div' not found" go to the file displayed in your error log and replace t3lib_div with \TYPO3\CMS\Core\Utility\GeneralUtility

PHP Fatal error: Class ‘tslib_pibase’ not found

02:48 PM by Christian Koch

Filed under php, t3 extension development

Last modified Wednesday September 9th, 2015

When you receive this error in TYPO3 6 or 7 go to the error file and replace class whatever extends tslib_pibase, the tslib_pibase with \TYPO3\CMS\Frontend\Plugin\AbstractPlugin

PHP Fatal error: Class ‘t3lib_extMgm’ not found

10:34 PM by Christian Koch

Filed under t3 extension development

Last modified Wednesday September 9th, 2015

replace t3lib_extMgm with \TYPO3\CMS\Core\Utility\ExtensionManagementUtility and done.

Typo3 4.7 2: SQL error: ‘Unknown column ‘tx_extbase_type’

12:28 AM by Christian Koch

Filed under t3 extension development

Last modified Friday September 21st, 2012

After a fresh install I suddenly received the error “2: SQL error: ‘Unknown column ‘tx_extbase_type’” after trying to ad a new frontend user group. To fix this problem

Typo3 4.7 Fatal error: Class ‘Tx_Extbase_Utility_Extension’ not found

12:06 AM by Christian Koch

Filed under t3 extension development

Last modified Friday September 21st, 2012

After a fresh install I received the error “Fatal error: Class ‘Tx_Extbase_Utility_Extension’ not found” in Typo3 4.7. To fix this issue just add

Typo3 4.7 TemplaVoila! (templavoila) “Sorry, you didn’t have proper permissions to perform this change.”

11:53 PM by Christian Koch

Filed under t3 extension development, typoscript

Last modified Monday July 30th, 2012

After installing a fresh Typo3 and integrating new Templates via TemplaVoia I suddenly received the error while entering a new Pagecontent Element: “Sorry, you didn’t have proper permissions to perform this change.”

Typo3 fluid assign HTML Code

11:09 AM by Christian Koch

Filed under t3 extension development

Last modified Friday May 11th, 2012

To assign html code to the corresponding fluid variable it has to be in one of the following fluid tags: